Version 1.2 does not work at all

Jan 19, 2012 at 10:47 PM

Version 1.2 does not work at all and seems to have been complie like the 1.1. Weird.

Jan 21, 2012 at 12:45 AM

Yes, in the manifest it is still listed as 1.1, so it won't upgrade from the actual 1.1 version.

If you uninstall 1.1 and install "1.2", VS gives an extension error on startup.

Coordinator
Jan 21, 2012 at 1:00 AM

Oops, missed the manifest. I'll fix it. If the extension is faulting you'll have to debug and give me an idea where the issue is. It's worked on all the systems I've tried which is the only testing I can do.

Jan 21, 2012 at 11:55 AM

Oh yeah, sorry for the lack of information on this problem, I just wanted to quickly inform the bug.

blueonion, thanks for your effort on this project, and thanks for correcting the problem.

Unfortunately I still have difficulties in making this extension work, when I compile project always gives an error.
I'm trying to investigate the cause...

Coordinator
Jan 21, 2012 at 12:02 PM
Edited Jan 21, 2012 at 12:21 PM

Thanks for looking into this. After thinking about this for a while, I think the issue may lie in the acquisition of the service provider interface. I've seen some talk on other forums that suggests that the service provider interface may not be ready when the an extension loads. I'll see if I can come up with an alternative of acquiring this interface through COM (OMG!) instead of MEF.

Writing VS extensions is a bit like alchemy. You just keep trying stuff till you get something interesting to happen.  

Jan 21, 2012 at 12:08 PM
Edited Jan 21, 2012 at 12:08 PM

Meanwhileit would be very difficult for you to send me the previous version (1.1)?

I miss it so much that I think it should have been incorporated into the VS.

Coordinator
Jan 21, 2012 at 12:13 PM
Edited Jan 21, 2012 at 12:20 PM

All previous versions are located on the Downloads page in the the "Other Downloads". Here's a direct link to Version 1.1.

Since you have a reproducible crash, do you mind testing a newer version later when it's ready? 

Jan 21, 2012 at 12:30 PM

Of course I cannot only that, if I can help in any way just tell me what I should do.

What I can not do rigth now is open VSColorOutput solution because I do not have intalled the SDK.

** I went back to version 1.1 and everything worked as expected. Thank you.

Coordinator
Jan 21, 2012 at 3:44 PM
Edited Jan 21, 2012 at 3:45 PM

First fix attempt: Download it here link:

Jan 21, 2012 at 4:03 PM

Unfortunately, it does not workI still see the same error and the text color in the output window is black, as the default behavior of VS.

Coordinator
Jan 21, 2012 at 4:07 PM

OK, check the event log. Maybe I caught the error there. Look for "Microsoft Visual Studio" sourced events.

Jan 21, 2012 at 4:40 PM
Edited Jan 21, 2012 at 4:47 PM

I found this mysterious error in event log: http://sharesend.com/info/316xa

I dont think its related with the issue, but I have not found anything else.

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
        <Provider Name="devenv" /> 
        <EventID Qualifiers="0">0</EventID> 
        <Level>2</Level> 
        <Task>0</Task> 
        <Keywords>0x80000000000000</Keywords> 
        <TimeCreated SystemTime="2012-01-21T17:26:47.000000000Z" /> 
        <EventRecordID>76561</EventRecordID> 
        <Channel>Application</Channel> 
        <Computer>Luis-PC</Computer> 
        <Security /> 
    </System>
    <EventData>
        <Data>The data source '{130bada6-e128-423c-9d07-02e4734d45d4}' specifies no supporting providers or a set that are not registered.</Data> 
    </EventData>
</Event>


Coordinator
Jan 21, 2012 at 5:24 PM

OK, lets try this one. Look in the application event log for any "Microsoft Visual Studio" errors and pass them along to me.

Jan 21, 2012 at 6:13 PM

The same result as above.

No event log, see for yourselfhttp://img833.imageshack.us/img833/9073/capturariw.png


The only error is that I mentioned earlier.

Coordinator
Jan 21, 2012 at 6:20 PM

This is sounding more and more like an assembly reference failing. Try running fuslogvw.exe and enabling fusion logging. Then run visual studio with the version of VSColorOutput that faults on your system.

Jan 21, 2012 at 6:59 PM
Edited Jan 21, 2012 at 7:00 PM

You was right!

I'm getting some assembly reference errors.

The logs are here: http://sharesend.com/xzv6w

I think you can face some problems with language (Brazilian portuguese), but it may be useful.

Coordinator
Jan 21, 2012 at 7:48 PM

The last message in the log indicates the assembly loaded successfully. I'm stumped at this point. Perhaps others will have something to say about this in a couple of days. Thanks for your efforts. 

Jan 21, 2012 at 7:59 PM

All of your tests were positive?

Uhnm, well, at least version 1.1 works fine.

Thank you very much for your work and support.

Coordinator
Jan 23, 2012 at 11:49 PM

Luis,

Give http://sharesend.com/kry69 a try.

Jan 24, 2012 at 9:03 AM

Unfortunately I'm still no luck.

Does the cause of the error would be this new functionality you implemented?

Anyway, thanks for keep trying.

Coordinator
Jan 24, 2012 at 12:59 PM

Another user reported an issue with a stack trace. I looks like the code that accesses the registry needs some attention.

Coordinator
Jan 24, 2012 at 10:44 PM

Luis, here one with the new registry code: http://sharesend.com/ykzxd

Jan 24, 2012 at 10:55 PM

heheyfinally it worked perfectly!

Congratulations and thank you for your effort.

Coordinator
Jan 24, 2012 at 10:58 PM

Yeah! The problem was glaringly obvious once I got a stack trace. Thanks for you help.

Jan 24, 2012 at 11:10 PM

blueonion,

One last question in this discussion, should I install the version on the download page or the one you sent me before is already the newest version?

Coordinator
Jan 24, 2012 at 11:13 PM

The one I sent you is the same as the download. No need to get the downloaded version.